Show full size 924Board.org
Discussion Forum of 924.org
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 
 Technical FAQ924 FAQ (Technical)   Technical924 Technical Section   Jump to 924.org924.org   Jump to PCA 924 Registry924 Registry

'82 NA Engine Pinging on initial sharp throttle

 
Post new topic   Reply to topic    924Board.org Forum Index -> General Discussions
View previous topic :: View next topic  
Author Message
XLR8  



Joined: 30 Mar 2016
Posts: 111
Location: Byron Bay, Australia

PostPosted: Thu Jun 07, 2018 5:33 pm    Post subject: '82 NA Engine Pinging on initial sharp throttle Reply with quote

Hi all, as per the title, I am experiencing pinging on initial sharp throttle "blip" (maybe 1/2 - 1 sec) and then she's all fine. Seems okay under load.

Any ideas?

Do I need to richen the mix a little?

Fouled injector causing a lean cylinder?

I don't think there are any vacuum leaks. I am running premium fuel and timing is set around 8deg BTDC.

Thanks in advance ....
_________________
'81 Porsche 924 NA
'89 Eunos Roadster NA6
'06 Landcruiser HDJ100
Back to top
View user's profile Send private message
Display posts from previous:   
Post new topic   Reply to topic    924Board.org Forum Index -> General Discussions All times are GMT + 11 Hours
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum


Powered by phpBB © 2001, 2005 phpBB Group